Recherche par filtres

Forums Forums WPshop Gestion des catégories Recherche par filtres

Ce sujet a 6 réponses, 2 participants et a été mis à jour par  rams, il y a 1 an et 7 mois.

7 sujets de 1 à 7 (sur un total de 7)
Auteur Messages
Auteur Messages
15 février 2016 at 11 h 43 min #19256

rams
Participant

Bonjour,
je rencontre un problème avec la recherche par filtre dans la page de ma catégorie d’article. les filtres fonctionne mais pas la réinitialisation des filtres quand je clique sure réinitialiser les filtres ou afficher tout dans la liste déroulante la liste des articles reste filtrée avec les filtres précédent.
Je ne trouve pas de solution à mon problème.
Merci

15 février 2016 at 14 h 36 min #19257

Gael
Admin bbPress

Bonjour,
une URL serait la bienvenue 😉
Merci
Cordialement, Gaël.

15 février 2016 at 22 h 24 min #19264

rams
Participant

Voila l’URL http://www.navi-reve.com/wpshop-category/bateaux/
j’ai essayer de place le shortcode à plusieurs endroit dans taxonomy-wpshop_product_category.php mais j’ai toujours le même problème

16 février 2016 at 10 h 15 min #19267

Gael
Admin bbPress

Bonjour,
effectivement soucis de notre part, ligne 42 et 46 du fichier WPshop/includes/modules/wps_search/assets/filter_search/js/wpshop_filter_search.js

jQuery("#" + id).val("").trigger("liszt:updated");
doit devenir :
jQuery("#" + id).val("all_attribute_values").trigger("liszt:updated");

et

jQuery( '.filter_search_radiobox, filter_search_checkbox' ).attr( 'checked', false );
doit devenir :
jQuery( '.filter_search_radiobox, filter_search_checkbox' ).attr( 'checked', true );

la prochaine mise a jour comprendra cette amélioration. Merci.

Cordialement, Gaël.

  • Cette réponse a été modifiée le il y a 1 an et 7 mois par  Gael.
16 février 2016 at 11 h 55 min #19268

rams
Participant

Merci pour votre réponse j’ai modifier le fichier mais la réinitialisation des filtres ne fonctionne toujours pas il y a quelque chose que j’ai manqué?
Cordialement.

16 février 2016 at 12 h 21 min #19269

Gael
Admin bbPress

Vous avez simplement commenté les lignes, il faut les remplacer.

Cordialement, Gaël.

16 février 2016 at 13 h 54 min #19271

rams
Participant

J’ai fait le bonne modification cette fois mais j’ai toujours le même problème, je sélectionne un constructeur dans la liste déroulante là pas de problème mais quand je clique sur réinitialiser les filtres un seul produit apparait.

Cordialement.

7 sujets de 1 à 7 (sur un total de 7)