Pas d'attribut préenregistrée

Forums Forums WPshop Affichage sur le back-admin Pas d'attribut préenregistrée

Ce sujet a 7 réponses, 2 participants et a été mis à jour par  Alexandre, il y a 3 ans et 11 mois.

8 sujets de 1 à 8 (sur un total de 8)
Auteur Messages
Auteur Messages
23 mai 2013 at 16 h 57 min #12025

WGlenat
Participant

Bonjour,

 

je viens d’installer WpShop et je n’ai pas d’attribut préenregistrée dans la rubrique attribut. Cela ne me semble pas « normal » d’après la documentation.

 

  • Ce sujet a été modifié le il y a 3 ans et 1 mois par  enzo degot.
27 mai 2013 at 17 h 15 min #12091

Alexandre
Admin bbPress

Bonjour,

Pourriez vous nous indiquer les informations ci-dessous:

– Version de wordpress
– Version de wpshop
– Type de serveur: WAMP / LAMP

Cdlt,

Alexandre

27 mai 2013 at 17 h 27 min #12095

WGlenat
Participant

Bonjour,

J’ai installé le plugin version 1.3.4.9 sur une base WP 3.5.1  sur un serveur LAMP

Cdt

28 mai 2013 at 9 h 49 min #12098

Alexandre
Admin bbPress

Bonjour,

Nous allons faire des tests pour voir d’ou vient le problème. Nous vous tiendrons au courant dès que nous en saurons plus.

Cdlt,

Alexandre

5 juin 2013 at 14 h 55 min #12159

Alexandre
Admin bbPress

Bonjour,

Nous avons effectué des tests mais n’arrivons pas à reproduire ce bug. Pour le corriger sur votre installation voilà la marche à suivre:

Dans l’onglet « Options avancées » (tout à droite de l’écran) du menu « Réglages -> Boutique » vous allez inscrire: « WPSHOP_DISPLAY_TOOLS_MENU » dans le premier champs et « true » dans le second puis enregistrer les réglages

Ce réglage doit avoir fait « apparaître » un nouveau menu dans « Outils » qui s’appelle « Wpshop – Outils »

Dans ce menu vous avez deux onglets:

– Aussi étrange que cela puisse paraître nous allons commencer par le second qui va permettre de vérifier la structure de la base de données: si il y a des erreurs, il faut cliquer sur les boutons réparer

– Une fois la structure globale nettoyée, dans le premier onglet on va vérifier les données manquantes et procéder à la réparation en cliquant sur chaque bouton tour à tour

Tenez nous au courant si vous rencontrez des difficultés.

Cdlt,

Alexandre

 

5 juin 2013 at 15 h 17 min #12160

WGlenat
Participant

 
Merci pour votre retour, concernant la structure de la base aucune erreur détectée, concernant les attributs on voit effectivement les attributs manquant mais la réparation ne se fait pas : pas de message d’erreur, mais pas d’attributs. J’ai pourtant essayé deux fois d’installer le plugin sur une nouvelle base vide et chaque fois le même résultat

5 juin 2013 at 16 h 32 min #12161

Alexandre
Admin bbPress

Bonjour,

Est ce que vous pourriez envoyer par email à dev@wpshop.fr une capture d’écran de chaque onglet, pour que nous puissions voir si nous détectons un problème que le plugin n’aurai pas détecté.

Attention les intitulés des onglets peuvent être trompeur, bien qu’il soit marqué « Structure de la base de données vérifiée » il se peut qu’il existe des erreurs

Cdlt,

Alexandre

6 juin 2013 at 14 h 58 min #12166

Alexandre
Admin bbPress

Bonjour,

Après des tests supplémentaires, nous avons pu isoler et reproduire ce bug.

Il vient de la version de php (2.5.6 dans ce cas)

La fonction file() de php ne supprime pas les retours à la ligne de fin de ligne alors que dans la version 5.4.3 sous laquelle nous développons supprime ce retour à la ligne.

Un correctif a été apporté il est référencé sous le numéro ST585 et sera livré dans la prochaine version de wpshop d’ici à demain

Cdlt,

Alexandre

8 sujets de 1 à 8 (sur un total de 8)