BOUTON AJOUTER AU PANIER

Forums Forums Général BOUTON AJOUTER AU PANIER

Ce sujet a 7 réponses, 2 participants et a été mis à jour par  la_mule, il y a 1 an et 5 mois.

8 sujets de 1 à 8 (sur un total de 8)
Auteur Messages
Auteur Messages
18 octobre 2015 at 15 h 27 min #18536

la_mule
Participant

Bonjour à tous

je rencontre depuis quelques jour un problème concernant le bouton  » ajouter au panier  »
lorsque je clique dessus, le bouton affiche le cercle de chargement indéfiniment.

Je fouiller dans tous mes réglages, mais rien n’y fait. Surtout que le bouton marchais auparavant…. peut être la dernière mise à jour qui pose problème …

Je fait appel à vous pour m’aider car le développement de mon site est stoppé à cause de ce problème.

19 octobre 2015 at 22 h 18 min #18540

la_mule
Participant

J’ai ciblé l’origine du problème….

sur la fiche produit, lorsque j’opte pour un affichage personnalisé, je décoche la case « afficher dans la fiche produit » qui correspond à l’attribut en question.

Et là le bouton ajouter au panier fonctionne…..

Mais j’ai besoin que cet attribut soit affiché pour permettre aux clients de faire leur choix.

Je ne sait plus où chercher pour solutionner mon problème.

20 octobre 2015 at 17 h 15 min #18543

Gael
Admin bbPress

Bonjour,
vous auriez une URL ou des screenshots pour illustrer vos propos ? Vous pouvez décrire le produit type qui ne fonctionne pas ?

Merci
Cordialement, Gaël.

20 octobre 2015 at 17 h 35 min #18546

Gael
Admin bbPress

Allez jeter un coup d’œil ici.

20 octobre 2015 at 21 h 26 min #18550

la_mule
Participant

Bonjour,

j’ai corrigé le fichier concerné à la ligne 967 mais cela ne résoud pas le problème….

for (var i=0; i < formData.length; i++) {
if ( !form_is_complete ) {
jQuery(‘.wpshop_cart_loading_picture’).addClass(‘error’);
jQuery(‘#wpshop_add_to_cart_form’).before( WPSHOP_PRODUCT_VARIATION_REQUIRED_MSG );
jQuery( ‘.wpshop_add_to_cart_button’ ).removeClass( ‘wps-bton-loading’ );
element = this;

voici le lien de l’article

http://oxygen3d.fr/catalog/saut-en-tandem-3000m/

  • Cette réponse a été modifiée le il y a 1 an et 5 mois par  la_mule.
21 octobre 2015 at 9 h 04 min #18552

Gael
Admin bbPress

Bonjour,

la ligne a été mal placé

if ( !form_is_complete ) {
jQuery(‘.wpshop_cart_loading_picture’).addClass(‘error’);
jQuery(‘#wpshop_add_to_cart_form’).before( WPSHOP_PRODUCT_VARIATION_REQUIRED_MSG );
jQuery( ‘.wpshop_add_to_cart_button’ ).removeClass( ‘wps-bton-loading’ );
element = this;
}

Elle doit être en dessous des accolades.

if ( !form_is_complete ) {
jQuery(‘.wpshop_cart_loading_picture’).addClass(‘error’);
jQuery(‘#wpshop_add_to_cart_form’).before( WPSHOP_PRODUCT_VARIATION_REQUIRED_MSG );
jQuery( ‘.wpshop_add_to_cart_button’ ).removeClass( ‘wps-bton-loading’ );
}
element = this;

Faites parvenir vos retours 🙂
Merci,
cordialement, Gaël.

  • Cette réponse a été modifiée le il y a 1 an et 5 mois par  Gael.
  • Cette réponse a été modifiée le il y a 1 an et 5 mois par  Gael.
  • Cette réponse a été modifiée le il y a 1 an et 5 mois par  Gael.
  • Cette réponse a été modifiée le il y a 1 an et 5 mois par  Gael.
  • Cette réponse a été modifiée le il y a 1 an et 5 mois par  Gael.
  • Cette réponse a été modifiée le il y a 1 an et 5 mois par  Gael.
  • Cette réponse a été modifiée le il y a 1 an et 5 mois par  Gael.
  • Cette réponse a été modifiée le il y a 1 an et 5 mois par  Gael.
21 octobre 2015 at 9 h 21 min #18561

Gael
Admin bbPress

Encore mieux
if ( !form_is_complete ) {
jQuery(‘.wpshop_cart_loading_picture’).addClass(‘error’);
jQuery(‘#wpshop_add_to_cart_form’).before( WPSHOP_PRODUCT_VARIATION_REQUIRED_MSG );
jQuery( ‘.wpshop_add_to_cart_button’ ).removeClass( ‘wps-bton-loading’ );
}
var element = document.getElementsByName(formData[i].name);

au lieu de

if ( !form_is_complete ) {
jQuery(‘.wpshop_cart_loading_picture’).addClass(‘error’);
jQuery(‘#wpshop_add_to_cart_form’).before( WPSHOP_PRODUCT_VARIATION_REQUIRED_MSG );
jQuery( ‘.wpshop_add_to_cart_button’ ).removeClass( ‘wps-bton-loading’ );
}
element = this;

21 octobre 2015 at 12 h 38 min #18570

la_mule
Participant

Bonjour

je vous confirme que votre dernier post est la solution à mon problème.

Tout re fonctionne parfaitement

Encore merci !

8 sujets de 1 à 8 (sur un total de 8)